Installation funktioniert nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Installation funktioniert nicht

    Hallo!
    Versuche gerade krampfhaft die Installation von nodePush in meiner Community. Bin nach dieser Anleitung gegangen, allerdings lässt sich nodePush nicht installieren:


    Quellcode

    1. 0 info it worked if it ends with ok
    2. 1 verbose cli [ '/usr/local/bin/node', '/usr/local/bin/npm', 'install' ]
    3. 2 info using npm@1.3.21
    4. 3 info using node@v0.10.24
    5. 4 warn package.json be.bastelstu.wcf.nodePush@1.0.0 No repository field.
    6. 5 verbose readDependencies using package.json deps
    7. 6 verbose install where, deps [ '/var/www/wcf/acp/be.bastelstu.wcf.nodePush',
    8. 6 verbose install [ 'socket.io',
    9. 6 verbose install 'express',
    10. 6 verbose install 'caterpillar',
    11. 6 verbose install 'caterpillar-human',
    12. 6 verbose install 'caterpillar-filter',
    13. 6 verbose install 'coffee-script',
    14. 6 verbose install 'chroot',
    15. 6 verbose install 'debug',
    16. 6 verbose install 'cors' ] ]
    17. 7 info preinstall be.bastelstu.wcf.nodePush@1.0.0
    18. 8 verbose readDependencies using package.json deps
    19. 9 verbose already installed skipping caterpillar@~2 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    20. 10 verbose already installed skipping caterpillar-human@* /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    21. 11 verbose already installed skipping caterpillar-filter@* /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    22. 12 verbose already installed skipping coffee-script@> 1.4 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    23. 13 verbose already installed skipping chroot@0.1.7 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    24. 14 verbose already installed skipping debug@~0.8 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    25. 15 verbose already installed skipping cors@* /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    26. 16 verbose already installed skipping socket.io@~1 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    27. 17 verbose already installed skipping express@~4 /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    28. 18 silly resolved []
    29. 19 info build /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    30. 20 verbose linkStuff [ false, false, false, '/var/www/wcf/acp' ]
    31. 21 info linkStuff be.bastelstu.wcf.nodePush@1.0.0
    32. 22 verbose linkBins be.bastelstu.wcf.nodePush@1.0.0
    33. 23 verbose linkMans be.bastelstu.wcf.nodePush@1.0.0
    34. 24 verbose rebuildBundles be.bastelstu.wcf.nodePush@1.0.0
    35. 25 verbose rebuildBundles [ '.bin',
    36. 25 verbose rebuildBundles 'caterpillar',
    37. 25 verbose rebuildBundles 'caterpillar-filter',
    38. 25 verbose rebuildBundles 'caterpillar-human',
    39. 25 verbose rebuildBundles 'chroot',
    40. 25 verbose rebuildBundles 'coffee-script',
    41. 25 verbose rebuildBundles 'cors',
    42. 25 verbose rebuildBundles 'debug',
    43. 25 verbose rebuildBundles 'express',
    44. 25 verbose rebuildBundles 'socket.io' ]
    45. 26 info install be.bastelstu.wcf.nodePush@1.0.0
    46. 27 info postinstall be.bastelstu.wcf.nodePush@1.0.0
    47. 28 info prepublish be.bastelstu.wcf.nodePush@1.0.0
    48. 29 error peerinvalid The package caterpillar does not satisfy its siblings' peerDependencies requirements!
    49. 29 error peerinvalid Peer caterpillar-human@3.0.0 wants caterpillar@^3.0.0
    50. 29 error peerinvalid Peer caterpillar-filter@3.0.0 wants caterpillar@^3.0.0
    51. 30 error System Linux 3.16.0-4-amd64
    52. 31 error command "/usr/local/bin/node" "/usr/local/bin/npm" "install"
    53. 32 error cwd /var/www/wcf/acp/be.bastelstu.wcf.nodePush
    54. 33 error node -v v0.10.24
    55. 34 error npm -v 1.3.21
    56. 35 error code EPEERINVALID
    57. 36 verbose exit [ 1, true ]
    Alles anzeigen
    Was mache ich falsch? Würde gerne den nodePush Server inkl. SSL nutzen (was ja kein Problem darstellen würde).
    Grüße