Fehlermeldung beim Update ​auf 4.0.0

  • Hi zusammen!


    Beim Update meines Chats auf 4.0.0 wird mir dieser Fehler angezeigt.


    An update of package be.bastelstu.chat from version 3.1.0 Beta 4 to 4.0.0 Alpha 160 is not supported.



    Stacktrace:

    #0 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/system/package/PackageInstallationScheduler.class.php(518): wcf\system\package\PackageInstallationScheduler->findShortestUpdateThread('be.bastelstu.ch...', Array, '3.1.0 Beta 4', '4.0.0 Alpha 160')

    #1 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/system/package/PackageInstallationScheduler.class.php(106): wcf\system\package\PackageInstallationScheduler->updatePackage('17', '4.0.0 Alpha 160')

    #2 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/system/package/PackageInstallationScheduler.class.php(67): wcf\system\package\PackageInstallationScheduler->tryToInstallPackage('be.bastelstu.ch...', '4.0.0 Alpha 160', true, false)

    #3 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/data/package/update/PackageUpdateAction.class.php(497): wcf\system\package\PackageInstallationScheduler->buildPackageInstallationStack(false)

    #4 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/data/package/update/PackageUpdateAction.class.php(449): wcf\data\package\update\PackageUpdateAction->createQueue('update')

    #5 [internal function]: wcf\data\package\update\PackageUpdateAction->prepareUpdate()

    #6 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/data/AbstractDatabaseObjectAction.class.php(196): call_user_func(Array)

    #7 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/action/AJAXProxyAction.class.php(77): wcf\data\AbstractDatabaseObjectAction->executeAction()

    #8 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/action/AJAXInvokeAction.class.php(96): wcf\action\AJAXProxyAction->invoke()

    #9 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/action/AbstractAction.class.php(49): wcf\action\AJAXInvokeAction->execute()

    #10 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/action/AJAXInvokeAction.class.php(63): wcf\action\AbstractAction->__run()

    #11 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/system/request/Request.class.php(58): wcf\action\AJAXInvokeAction->__run()

    #12 /mnt/web114/e1/53/53332353/htdocs/wbb4/wcf/lib/system/request/RequestHandler.class.php(139): wcf\system\request\Request->execute()

    #13 /mnt/web114/e1/53/53332353/htdocs/wbb4/acp/index.php(10): wcf\system\request\RequestHandler->handle('wbb', true)

    #14 {main}



    Kann jemand Helfen, wie bekomme ich das Update doch noch durch.



    Gruss

    Frank

  • Du kannst den Chat noch nicht aktualisieren, musst ihn daher deinstallieren und in der Woltlab Suite dann neu installieren, steht auch so im Forum hier...


    Zudem scheint es irgendwie so als versuchst du den Chat in einem WBB4 zu installieren, das geht natürlich nicht, der ist für die Woltlab Suite 3.1 gedacht.

  • Hi Erazor!


    Danke für die schnelle Antwort :thumbsup:


    Habe es im Forum leider Übsersehen, sorry.

    Also gibt es für das 4er kein Update, so das der alte Chat erhalten bleiben sollte, oder was muss ich da tun.



    Gruss

    Frank

  • Du meinst bei einem Upgrade auf die Woltlab Suite?

    Vorläufig Nein, die Version für die Woltlab Suite 3.1 ist noch in Entwicklung und nicht für den Betrieb in einem produktiven Forum vorgesehenne


    Zudem ist (soweit ich weiss) auch noch nicht klar ob bei einem Upgrade der Chat automatisch aktualisiert wird oder zuerst deinstalliert und dann im neuen Forum neu installiert werden muss.


    Solltest du bei Version 4.x bleiben ist kein Update notwendig, es gibt keine wirklichen "neuen" Features... Es ist nur eine Anpassung der aktuellen Version von 4.x an die Woltlab Suite 3.1


    Grüsse,

    Era

  • Tim

    Hat das Label Funktioniert wie gewollt hinzugefügt