Beiträge von Afox

    wenn ich npm update eingebe wiederholt er immer das Gleiche:

    hi, Ergebnis (wenn ich es richtig gemacht habe):

    Zitat

    TypeError: undefined is not a function
    at Object.<anonymous> (/Pfad/zum/Forum/wcf/acp/be.bastelstu.wcf.nodePush/app.coffee:26:15)
    at Object.<anonymous> (/Pfad/zum/Forum/wcf/acp/be.bastelstu.wcf.nodePush/app.coffee:1:1)
    at Module._compile (module.js:456:26)

    Hi,


    ich habe gerade versucht via npm update zu updaten und daraufhin wirft er einen Fehler:


    Gruß,


    Afox

    Hallo,


    ich habe den Chat von Chris und das Problem, dass wenn mehrere Tabs geöffnet sind, eingehende Nachrichten teilweise auf mehrere Tabs verteilt werden und erst bei einem Neuladen wirklich die gesamte Nachricht angezeigt wird.


    Hat jemand zufällig eine Idee wie man dem begegnen kann?


    Gruß,


    Afox

    das Problem lag darin, dass die Font-Awesome-Icons in den neueren Verisonen umbenannt wurden und deshalb das entsprechende Icon natürlich nicht mehr gefunden wurde.


    Danke an Sascha für die tolle Hilfe!

    Hallo,


    ich habe das Problem dass bei mir in der Forenauflistung im ACP nicht das entsprechende Icon neben dem dem entsprechenden Forum angezeigt wird sondern das ganz normale Ordner Symbol.


    Gehe ich auf bearbeiten eines Forums, so ist dort auch kein Symbol ausgewählt obwohl im Frontend eines angezeigt wird. Ich hatte jedem Forum nämlich vor ewigen Zeiten schon ein passendes Icon zugewiesen.


    Das scheint aber jetzt irgendwie verloren gegangen zu sein.


    WCF 2.1.14
    WBB 4.1.13
    Font Awesome Icon Util 1.2.3


    Als einzige Erklärung für dieses Verhalten fällt mir eigentlich nur ein Update des Font Awesome Icon Utils ein. Oder die Font-Awesome Erweiterung von Sascha - aber die ist nicht in den Abhängigkeiten gelistet.


    Gruß,


    Afox

    klar, das kann ja sein und ich bin sehr dankbar für den Artikel weil mich das schon immer interessiert hat. Dennoch finde ich so etwas nicht unerheblich. Auch weil wir Ressourcen schonen sollten.


    Ich habe gerade mal weil es mich interessiert hat nachgerechnet: 14KB/Sekunde das sind 421,05 GB/Jahr.


    Wohlgemerkt fast im Idle-Zustand, da ich in dem Forum ausschließlich mit einer Person angemeldet war (keine Bots) und eigentlich nichts gemacht habe.


    Im laufenden Betrieb habe ich noch keine Werte.

    Hallo,


    wenn ich auf der Startseite des Forums bin und jemand schreibt einen Beitrag in einem abonnierten Thema so leuchtete bei mir (Firefox) zwar die Zahl z.B. im Forum-Tab auf, jedoch war die Zahl eine 0 - was ja eigentlich nicht sein kann. Erst nach dem Neuladen der Seite wurde eine 1 dargestellt.


    WCF-Version: 2.1.12, BB-Version: 4.1.12, nodepush 1.1.0


    Gruß,


    Afox

    Hallo,


    ist es irgendwie möglich die Schreiblast des Chat auf die Festplatte zu reduzieren?


    Bei mir schreibt er im Mittel 14KB/Sekunde mit aktiviertem Chat, ohne sind es nur etwa 1KB/Sekunde.


    Für jeden Tipp bin ich sehr dankbar.


    Gruß,


    Afox

    also kleines Update: die genannte Fehlermeldung haben wir jetzt behoben indem wir in der app.coffee den Wert für requestCert auf false gesetzt haben. Gibt es hierzu zufällig irgendwelche Sicherheitsbedenken? Funktionieren tut es ^^

    ok, danke :)


    muss man denn zwingend den Port über den Apachen aufrufen oder kann man ihn auch direkt aufrufen? Auch über SSL?


    Gruß,


    Afox

    hallo, geht das mit dem Reverse Proxy auch mit dem Apache? ich habe gerade nochmal die Seite mit einem Android Endgerät aufgerufen und erhalte folgende Meldung:

    Zitat

    Kein Zertifikat gefunden


    Die Anwendung Internet hat ein Zertifikat angefordert. Wenn Sie ein Zertifikat wählen, wird die Anwendung diese Identität jetzt und in der Zukunft mit Servern benutzen können. Die Anwendung hat den Server, von dem die Anforderung kommt, als meinedomain.tld:#Nodeport# identifiziert, aber Sie sollten der Anwendung nur dann Zugang zum Zertifikat geben, wenn Sie der Anwendung vertrauen. Sie können Ziertifikate von einer PKCS#12 Datei mit einer .pfx oder einer .p12 Erweiterung, die sich im externen Speicher befindet, installieren.

    Ist dieser Fehler darauf zurückzuführen dass kein Reverse Proxy eingerichtet wurde? *help*