Beiträge von Shorty

    Was genau muss man den alles machen um den Reverse-Proxy (nginx) dafür ein zu richten?


    In Plesk ist der nginx schon Aktiviert und das nodepush.example.com muss ich durch meine Domain ersetzen und muss ich bei proxy_pass http://127.0.0.1:10004; noch was ändern?



    In welcher vHost genau müsste ich den Code einfügen und an welcher stelle?

    Was genau muss man den alles machen um den Reverse-Proxy (nginx) dafür ein zu richten?


    In Plesk ist der nginx schon Aktiviert und das nodepush.example.com muss ich durch meine Domain ersetzen richtig?


    In welcher vHost genau müsste ich den Code einfügen und an welcher stelle?

    So ich Update das hier mal in der Hoffnung das sich endlich mal jemand dem Support an nimmt,ich habe den Fehler oben nun wie es aussieht beheben könnend er Code sahs an einer Falschen stelle.


    Wenn ich im Anhang die ausgabe von Putty richtig Deute ist der NodePush sever gestartet,aber wenn ich nun https://computer-base.net:10004/ aufrufe bekomme ich Diese Webseite ist nicht verfügbar. ERR_CONNECTION_TIMED_OUT

    Ich weiss das mir die Fehlermeldung Error: ENOENT, no such file or directory 'https://computer-base.net/wcf/acp/be.bastelstu.wcf.nodePush/computer-base.key' nicht finden kann,aber genau das verstehe ich nicht sie Liegt genau in dem Pfad der angegeben ist und ist auch genau so benannt.


    Also kann das do eigentlich nicht der Fehler sein oder verstehe ich da etwas nicht?


    Kann es daran liegen das Plesk eigentlich die Hochgeladenene Zertifikate Verschlüsselt und ich die Dateien selber erstellt habe und selber mit .crt und .key benannt habe,das sie deshalb nicht erkannt werden?

    Hallo ich habe es nun endlich nach sehr langem suchen und gefühlte 1000 mal testen bis es läuft,glaibe ich geschaft das nodePush schon mal ohne SSL Funktioniert wenn ich comuter-base:10004 aufrufe bekomme ich.

    Code
    1. Up since: Tue Dec 16 2014 21:26:25 GMT+0100 (CET)
    2. Outbound: 0 now

    Angezeigt das bedeutet doch das er Läuft oder?


    Dann habe ich versucht nach diesem Thread SSL in mit SSL zum Laufen zu bekomen aber da bekomme ich nun wenn ich npm start eingebe Folgenden fehler.


    Ich muss mich hier noch mal melden ich habe nun in Plesk unter Zusätzliche Nginx-Anweisungen Folgendes angegeben.

    Nach dem Abspeichern bekomme ich Folgenden Fehler.


    Code
    1. Ungültige Nginx-Konfiguration: nginx: [emerg] "server" directive is not allowed here in /var/www/vhosts/system/computer-base.net/conf/vhost_nginx.conf:7 nginx: configuration file /etc/nginx/nginx.conf test failed


    Was bedeutet das?


    Sorry das ist das erste mal das ich mir sowas einrichten möchte,aber es ist sehr Kompliziert wenn man sich damit überhaupt nicht auskennt.

    Hallo ich habe es nun anschein nach nächte langem Googlen und suchen geschaft es zum Laufen zu bekommen,es gibt nur noch Fein heiten denke ich mal die behoben werden müssen wie z.b. dieser aus der npm-debug.log der beim npm starrt ausgegeben wird.


    Putty ausgabe:

    npm-debug.log:


    Was bedeutet das und wie kann ich das beheben?


    *EDIT*
    Ich habe node.js und npm über root Installiert und nicht über den Kunden/Benutzer im Verzeichnis /wcf/acp/be.bastelstu.wcf.nodePush/,kann das zu dem Fehler führen?


    *EDIT2*
    Wenn ich die Pfade zu den SSL zertifikate angebe bekomme ich einen 502 Bad Gateway nginx,wie kann ich das beheben?


    *EDIT3*
    ich möchte es bei Zwei Domains anwenden bei der einen computer-base.net sieht es nun so aus als Klappt alles bei der anderen wbb-area.eu bekomme ich immer noch 502 Bad Gatewy/nginx aber beide Domains haben überall Exakt die selben einstellungen.


    Wie kann das möglich sein?

    Hallo danke aber wenn ich mich als der Benutzer einlogge für den es ist und das npm start ausführe in dem Verzeichnis /wcf/acp/be.bastelstu.wcf.nodePush/ bekomme ich.


    Code
    1. bash-4.3$ npm start
    2. bash: npm: command not found

    *EDIT*
    Habe es wider Deinstalliert hat noch Probleme mit den benachrichtigungen gegeben.

    Hallo ich habe über Google bei github die Version nodePush 2.0.0 Beta 2 gefunden und mir diese nun anstelle der aus dem Plugin Store Installiert,die node.js Installation und das npm install hat soweit ich das erkennen kann geklappt


    Ich loge mich mit root über SSH und Putty auf meinem Server ein und wechsel dann in das verzeichniss /var/www/vhosts/computer-base.net/httpdocs/wcf/acp/be.bastelstu.wcf.nodePush/ wenn ich dort dann npm star ausführe bekomme ich.


    Was stimmt nicht und wo muss ich was in der app.coffee ändern?

    Hallo ich nutze das Foren Icon Plugin in einem wBB 4.0 und benutze ein SSL Zertifikat,das zeigt auf der Startseite ein Problem an was ich mit Firefox Firebug Lokalisieren konnte.


    Wo kann ich das http nun in https ändern,in der Datenbank habe ich schon nach gesehen da ist nichts vorhanden.