Beiträge von HeikoH

    Hallo Tim,


    ich bin vor etwa einer Woche nun endlich mal dazu gekommen den Chatroom in meinem Forum zu installieren. Vor 3 Tagen hat sich nun ein Mitglied meiner Community bei mir gemeldet und mir geschrieben dass er Probleme bei der Benutzung des Chatrooms hat. Wenn er sich in den Chatroom einloggt, bekommt er gleich eine Fehlermeldung und kann dann auch nichts machen, außer den Chat wieder über den Logout-Button zu verlassen. Die Fehlermeldung lautet: "Der Chat konnte nicht ordnungsgemäß initialisiert werden: Can't find private variable: @derivedConstructor".


    Andere Mitglieder scheinen aber keine Probleme zu haben, auch ich selbst nicht. Ich habe mir dann mal sein Passwort geben lassen und habe mich selbst unter seinem Benutzerkonto in den Chat eingeloggt. Bei mir funktionierte unter seinem Benutzerkonto aber auch alles einwandfrei und es gab diese Fehlermeldung nicht. Dass es an seinem Betriebssystem oder den verwendeten Webbrowser liegt, kann ich wohl ausschließen, denn ich selbst verwende das gleiche Betriebssystem (MacOS Mojave) in der gleichen Version und auch den gleichen Webbrowser (Safari) in der gleichen Version wie er. An seinem Benutzerkonto selbst kann es ja aber auch nicht liegen, dass habe ich ja getestet, indem ich mich mit seinem Benutzerkonto eingeloggt und den Chat getestet habe.


    Hast Du (oder auch gerne jemand anderes) noch irgendeine Idee wo das Problem liegen kann bzw. wie ich meinem Mitglied weiter helfen kann?

    Hallo Tim,


    das hatte ich bereits versucht, deshalb auch meine Frage. Wenn ich im ACP den Trigger lösche und dann im Chat in der Online-Liste auf einen Namen klicke, steht der Befehl zum Flüstern immer noch im Menü.

    Vor Allem halte ich löschen für nicht so gut, kann ja sein dass ich den zuvor gelöschten Befehl doch irgendwann mal wieder haben möchte. Kann man das nicht so machen, dass man einzelne Befehle deaktivieren kann? Ich habe zum Beispiel den Bot von Udo Z und da gibt es bei jedem angelegten Bot immer eine Checkbox mit der Bezeichnung "Bot deaktivieren". Damit lässt sich dann ein einzelner Bot eben deaktivieren, sodass man ihn nicht komplett löschen muss. Wäre das mit den Chat Befehlen nicht auch möglich?

    Erstmal vielen Dank für Eure Antworten!


    Das "Problem" mit deinem Download lässt lediglich darauf schliessen dass in dem Download-Ordner zum Zeitpunkt des Herunterladens bereits eine Datei mit dem selben Namen existiert hat. Da logischerweise nicht zwei Dateien mit dem exakt selben Namen im gleichen Ordner liegen können wurde die Datei umbenannt.


    Ja, das ist mir eigentlich schon bekannt, aber ich dachte, ich hätte die alte Datei längst gelöscht, aber dem war wohl doch nicht so. :)



    Ich kann die Datei egal unter welchem Namen problemlos installieren, ich vermute du hast bei der Installation einfach eine korrupte/(oder eben die falsche) Datei versucht hochzuladen...


    Komisch, bei mir geht das eben nicht, wenn die Datei nicht den originalen Namen hat. Eine korrupte oder falsche Datei kann ich ja nicht benutzt haben, denn ich habe mir die Datei ja mehrmals herunter geladen. Nur hatte ich eben immer wieder das selbe Problem, eben dass sie sich einfach nicht installieren ließ. Nachdem ich dieses "-2" dann aus dem Dateinamen gelöscht hatte, ließ sich der Chat ja auch einwandfrei installieren. Das zeigt mir, dass es wohl doch am Dateinamen gelegen haben muss.



    Zu deinem zweiten "Problem" findest du hier die Antwort:


    Designänderungen - Contentbereich vergrößern


    Danke für den Tipp / Link, werde ich mir dann bei Gelegenheit mal ansehen.



    Damit wir gleich 'n weng mehr lernen: Diese Funktion nennt sich "autoincrement" und beschreibt die fortlaufende Erhöhung eines Zahlenwerts, hier ganzer Zahlen. (<- Eigene Definition zur Begrifflichkeit).


    Dein (ich denke mal) Windows X bedient sich der Funktion, damit nicht dein(e) erster/n, gleichnamiger/n Download/s von dem jeweils neusten Download überschrieben wird/en.

    Mach dir kein Kopf darüber, selbst Experten stockten als die Funktion eingeführt wurde (wenigstens einige Zehntelsekunden), bis es dann Klick gemacht hat und die Situation begriffen und verinnelicht wurde.


    Diesbezüglich brauche ich eigentlich nichts mehr zu lernen, ich bin nun nicht gerade ein Anfänger was PC´s anbelangt. Wie oben schon geschrieben, ist es mir schon bekannt, dass Dateien automatisch umbenannt werden, wenn es den selben Dateinamen doppelt gibt. Ich bin aber fälschlicher Weise davon ausgegangen, dass ich die alte Datei längst gelöscht hatte, da hatte ich mich dann aber wohl geirrt. ^^

    Wegen dem Betriebssystem: ich nutze sowohl MacOS als auch Windows 10. Habe hier einen iMac stehen, auf dem ich beides installiert habe, wobei ich Windows aber eigentlich nur noch für meine Spiele nutze. ;)

    Ich habe mal eine kleine Anmerkung zu der neuesten Beta Version bzw. zum Download dieser Version. Und zwar hatte ich mir mit der Beta Version davor ja mein Testforum komplett zerschossen und habe dieses deshalb gestern mal komplett neu aufgesetzt, weil ich jetzt die aktuellste Beta ausprobieren wollte. Ich habe also auch alle Pakete aus dem ersten Beitrag dieses Themas hier zuerst wieder neu installiert und mir dann die aktuellste Beta des Chats herunter geladen. Als ich diese dann installieren wollte, gab es immer nur irgendeine Fehlermeldung, die ich aber nicht mehr im Kopf habe. Ich habe mir die Datei dann mehrmals wieder neu herunter geladen, aber die Installation wollte einfach nicht klappen. Dann ist mir irgendwann schließlich folgendes aufgefallen: im Beitrag mit der angehängten Datei nennt sich die Datei "be.bastelstu.chat.tar.gz", wenn ich die Datei aber herunter lade, heißt sie "be.bastelstu.chat.tar-2.gz". Das hat mich ein wenig gewundert und ich habe deshalb einfach das "-2" aus dem Dateinamen gelöscht und siehe da, danach klappte auch plötzlich die Installation. :) Ich weiß nicht, ob nur ich dieses Problem habe, aber ich wollte vorsichtshalber einfach mal darauf hinweisen. ;)


    Edit: habe noch eine Frage, die ich vergessen habe: lässt sich eigentlich irgendwo die Höhe des Chatbereiches einstellen? Mir kommt es irgendwie so vor als wenn beim Chat hier im Forum mehr Platz, also mehr Nachrichten lesbar sind, als in meinem Testforum.

    Danke für die Info, Max, aber das wird nicht mehr gehen, denn ich habe aus Versehen das Chat Verzeichnis per FTP gelöscht. ^^

    Naja, dann ist mein Testforum wohl leider zum Teufel, bin ich froh, dass es nicht das normale Forum war... :S

    Ich habe auch gerade die aktuellste Version des Chats getestet und bekomme auch nur noch eine Fehlermeldung angezeigt. Handelt es sich hier um den selben Fehler:



    Sieht für mich, als Laien, zumindest so aus. Jedenfalls komme ich jetzt gar nicht mehr an mein Testforum, beim Aufruf kommt nur noch diese Fehlerseite und nichts Anderes mehr. Was mache ich da nun?

    In dem Zusammenhang hätte ich auch nochmal eine kurze Frage: wenn es die finale Version des Chats gibt, brauche ich dann die ganzen zusätzlichen Pakete auch weiterhin noch, also müssen die auch weiterhin mit installiert werden?

    Der Chat läuft aber auch unter Version 3.0 der Woltlab Suite einwandfrei, zumindest habe ich damit bisher eigentlich keine Probleme und ich bin auch Nutzer der 3.0 Version. Der Chat sollte nur (noch) nicht produktiv eingesetzt werden, aber solange er erstmal nur für 2 oder 3 Admins genutzt wird und für die restlichen Benutzer nicht nutzbar ist, denke ich dass es wohl keine Probleme geben dürfte.

    Das Template ist an dieser Stelle statisch, es beachtet auch nicht, um ein Trigger umbenannt wurde. Passe bitte einfach das Template an: userListDropdownMenuItems.


    Das habe ich gerade mal ausprobieren wollen, geht aber leider nicht. Suche ich mir dieses Template im ACP heraus, ist der Stift zum Bearbeiten ausgegraut und es lässt sich deshalb nicht bearbeiten/anpassen. Oder muss ich das irgendwie anders machen?

    Ich habe gestern mal die neueste Version des Chats installiert und die Sache mit dem Logout-Button getestet. Scheint aber meiner Meinung nach noch nicht wirklich zu funktionieren bzw. nur halb. Klicke ich den Logout Button an, lande ich bei meinem Testforum zwar auf der Startseite, werde aber in der Onlineliste des Chats noch weiterhin als online angezeigt. Ich habe das mit zwei Räumen getestet, zum einen den Raum "Default" und ich habe einen zweiten Raum angelegt. Ich war dann in beiden Räumen eingeloggt... Dann habe ich mich über den neuen Logout-Button aus meinem selbst erstellten Raum ausgeloggt und wurde dort auch nicht mehr als online angezeigt. Dann habe ich mich auch aus dem Raum "Default" über den Button ausgeloggt, wurde dort aber weiterhin als online angezeigt. Hier habe ich das eben auch nochmal ausprobiert und hier ist es genauso, logge ich mich aus einem Raum aus, werde ich trotzdem noch weiterhin als online angezeigt.

    Ich hätte nochmal eine Frage zum Chat: wird es auch möglich sein einzelne Befehle zu deaktivieren? Ich meine z.B. den Befehl zum Flüstern (whisper). Ich habe gestern die neueste Version des Chats installiert und mich mal im ACP danach umgesehen, konnte bisher aber keine Möglichkeit dazu finden. Man kann zwar einzelne Befehle einfach löschen, aber wenn ich dann im Chat in der Online-Liste auf den Namen eines Mitglieds klicke, dann wird der entsprechende (gelöschte) Befehl dort noch weiterhin angezeigt und führt dann bei Benutzung einfach nur zu einer Fehlermeldung.

    Tim brauchte eben die Woche noch um wichtige Private Dingen zu erledigen die während der Prüfungszeit liegen geblieben sind und das ist auch ok so.


    Dagegen ist ja auch absolut nichts einzuwenden und es ist in der Tat vollkommen OK! Ich wollte damit ja nur sagen, dass nirgendwo geschrieben steht, dass das Warten in absehbarer Zeit ein Ende hat, nicht mehr und nicht weniger. Und wenn einem die Nutzer der Plugins auf die Nerven gehen, dann muss man eben keine Plugins anbieten, ist doch ganz einfach. ;)

    ...

    Es ist gut zu wissen, das bei der Wartezeit langsam ein Ende absehbar ist...


    Wo steht das, dass bei der Wartezeit langsam ein Ende abzusehen ist? Es hat doch niemand geschrieben dass die finale Version des Chats in absehbarer Zeit erscheint. Es kann doch durchaus noch 1 Jahr dauern, wer weiß das schon so genau. ;)