Authentifizierung nicht möglich. Code immer ungültig./Alle Administratoren ausgeschlossen

  • Hallo,


    es wurde versehentlich eine Einstellung gemacht und nun sind alle Administratoren vom ACP ausgeschlossen um die Funktion zu deaktivieren.
    Wir haben bereits die Serverzeit date -s [Zeit] eingestellt, da im Forum immer eine Stunde versetzt war nur weiterhin ohne Erfolg.
    Ist es irgendwie möglich, dass wir wieder Zugriff zum ACP bekommen?

  • Hi,


    du solltest einen Emergency-Code bekommen haben. Diesen kannst du verwenden.


    Ansonsten folgende Query ausführen (vorher Backup, denn die Query ist ungetestet):


    SQL
    1. UPDATE wcf1_user SET twofaSecret = NULL;
  • Wir kommen alle nicht mehr rein. Wenn man sich im ACP einloggen will, kommt nur die Meldung, dass dazu der Accounts authentifiziert sein muss.
    Allerdings wird bei jedem wenn er dies machen möchte, der Code als ungültig ausgegeben.
    Wir dachten es könnte evl. an der Serverzeit liegen, aber diese haben wir korrekt eingestellt.



    Nun ist es sehr ärgerlich, dass wir aufgrund des Plugins keinen ACP Zugriff mehr haben.

  • Hast du denn die obengenannte SQL-Abfrage mal gemacht?

    noch nicht, Kollege macht das mit den Datenbanken. Also manuell über die Konsole, hab da keine Ahnung von aber er wird es dann ausprobieren.


    Ich habe hie noch eine Anleiung gefunden. Welche wäre denn effektiver?

  • Dann ist die Query oben irrelevant.


    Dann musst du folgende Query ausführen:


    UPDATE wcf1_option SET optionValue = 0 WHERE optionName = 'twofa_acp_require';


    Und danach die Datei options.inc.php im WCF-Verzeichnis löschen.


    Grüße.