No anonymous option

  • please add a screenshot of your board settings. Did you check "Force anonymization" in your board settings (see attached screenshot)?

    No I do not force anything.


    I have also tried all 4 options (hash, name, anonymous, and also selecting nothing at all)


  • Hi


    just to be sure, what exactly is the issue:

    • Users cannot create anonymized posts in the given board.
    • Users can only create anonymized posts, but should be able to create non anonymized posts in the given board as well.
    • A different issue
  • Hi


    based on your comment in the plugin store I thought the issue was "Users can only create anonymized posts, but should be able to create non anonymized posts in the given board as well". Anyway: Did you make sure to set proper permissions for the groups (second tab on the board settings)?

  • Hi


    based on your comment in the plugin store I thought the issue was "Users can only create anonymized posts, but should be able to create non anonymized posts in the given board as well". Anyway: Did you make sure to set proper permissions for the groups (second tab on the board settings)?

    No groups are selected there, ever. I use only group permission settings and do not assign forum permissions. If that is a requirement, I would ask that you please defer to group permission's only.

  • Hi


    yes it is a requirement and no, I won't lift it. Usually one does not enable anonymous posting in each and every area of his forum, but in selected areas and my target is the average user. If you want to use this plugin in your whole board you have to set the permission for at least each top level board, it will be inherited down the board structure.

  • Hi


    yes it is a requirement and no, I won't lift it. Usually one does not enable anonymous posting in each and every area of his forum, but in selected areas and my target is the average user. If you want to use this plugin in your whole board you have to set the permission for at least each top level board, it will be inherited down the board structure.

    This worked, but it required me to have to approve the post. Not sure why that was.

  • Hi

    This worked, but it required me to have to approve the post. Not sure why that was.

    because you decided so. "Anonymized posts have to be enabled", first post, second screenshot, at the top.