ImageProxy im Zusammenhang mit weiteren Parametern

  • Hallo,
    gibt ein User eine Signatur mit folgendem Inhalt an, reagiert der Proxy nicht darauf, sprich das Bild wird nicht gecached.


    Code
    1. [align=center][url='http://www.mod-images.de/image/IWl'][img='http://www.mod-images.de/images/aaaReddAxe_YouTube.md.png',none,260][/img][/url][url='http://www.mod-images.de/image/IW6'][img='http://www.mod-images.de/images/aaavirtualfarming.md.png',none,251][/img][/url][/align]


    Schaut man sich hiervon den Quellcode an, so bleibt der Link in der Ausgangsform vorhanden und wird somit für die SSL-verbindung als unsicher eingestuft.
    Entfernt man die Parameter, also ,none,260 so wird es zu einem ImageProxy-Link, allerdings ist dieses Bild dann nicht aufrufbar.
    Der Quellcode davon sieht dann wie folgt aus:


    HTML
    1. <a target="_blank" class="externalURL" href="http://www.mod-images.de/image/IWl"><img alt="" class="" src="https://nkb-modding.com/index.php/ImageProxy/?image=9e6e5e92ee5db0c5ebf7a02b0aea8c09c52c7bd4-aHR0cDovL3d3dy5tb2QtaW1hZ2VzLmRlL2ltYWdlcy9hYWFSZWRkQXhlX1lvdVR1YmUubWQucG5nJw%3D%3D">[/img]</a>

    Hovert man nun im Firebug über den Link, sodass dort im Normalfall eine kleine Preview des Bildes gezeigt wird, erhält man folgende Meldung: Die angegebene URL konnte nicht geladen werden.


    Einen Beitrag mit dieser Signatur findest du hinter folgendem Link: https://nkb-modding.com/index.…e/?postID=52713#post52713 (User ReddAxe)



    Ich wäre dir sehr dankbar, wenn du dich diesem Problem noch annehmen würdest.


    Für weitere Rückfragen stehe ich dir gerne zur Verfügung.

  • Ich muss mal schauen, wann ich dazu komme. Ich habe hier noch eine riesige ToDo-Liste. Offiziell habe ich hier allerdings den Support eingestellt, da das Feature mit 2.2 umgesetzt wurde.