Tims Chat 4

  • Hallo,


    aktueller Plan: Bis zum 25. Juli steht bei mir Klausurphase an. Anfang August möchte ich gerne eine „RC 1“ veröffentlichen, die dann auch in den Pluginstore kommt und ein Update auf Tims Chat 4.0.0 garantiert.

  • Hi Tim and the grateful team,

    bevor ihr launcht wollte ich euch nochmal etwas ins Gedächtnis rufen.

    Circa 95% deiner zukünftigen Erst-Nutzer (Beta-Tester) von eurer Chat-Software werden die folgenden Sprachvariablen-Kategorien & deren Sprachvariablen und eventuell sogar noch andere Komponenten, die ich jetzt nicht auf dem Schirm habe, die dann aber obsolet werden, bei einem event. Risiko von Cross-Dependencies.

    Kein Problem, wenn die Kategorien und Variablen wiederverwendet werden

    Kein Problem, wenn sie während der Installation geändert werden.

    Kein Problem, wenn sie gelöscht werden, zumindest die obsoleten, verwaisten. [Was die beste Wahl meiner Meinung nach wäre.]

    Ansonsten bitte eine Empfehlung zum Löschen von Kategorien und deren Variablen in der Datenbank durch die Nutzer selbst geben, damit wir sie dort löschen können.


    Viele Grüße



  • Tim hat an mehreren Stellen bereits gesagt, dass bewusst die Kompatibilität am Ende gebrochen wird. Du kommst also um eine Neuinstallation gar nicht drum herum und somit werden diese Inhalte bei einer Deinstallation des bisherigen Chat-Paketes sowieso alle Inhalte desselben entfernt.

  • entfernt.

    Hallo Black Rider,

    leider hast Du es nicht verstanden.

    Ich habe den Chat bereits beim Upgrade von 4.1 auf 3.0 vor fast zwei Jahren deinstalliert (deinstallieren müssen!), weil nur so damals das Upgrade auf die Suite erfolgen konnte.

    Deshalb habe ich gar keinen Chat mehr, den ich deinstallieren könnte, weil er bereits Dez. 2016 deinstalliert wurde, mit dem Resultat, daß die Chatleichen und mehr (!) zurückblieben.

    Was denkst du warum ich Tim so eindringlich und doppelt warne?

    Bei der Deinstallation von Tims Chat 3 (für WBB 4.1) wird oder wurde nur rudimentär deinstalliert.

    Damit betrifft es alle Woltlab + Tims Chat Nutzer, die das Upgrade von WBB 4.0, 4.1 auf die Suite 3.0/3.1 vollzogen haben und hierfür den Chat zwingend deinstallieren mussten.

    Mit dem neuen 4.0.0 oder seiner jetzigen/kürzlichen Test-Derivate/Betas hat das null und gar nichts zu tun. Denn die hatte ich in nur in neu-aufgesetzten TEST-Installs, jedoch nie in meinen 3 produktiven Communities. wo früher Tims Chat 3 lief.


    Es blieben über alle Updates und Upgrades entlang der Suite 3.0 und 3.1 verwaiste Dateien und mindestens Sprachvariablen-Leichen aus Chat für 4.1 zurück.


  • Dann musst du das auch direkt entsprechend schreiben, denn das war aus deinem vorherigen Beitrag nicht herauszulesen.


    Ich glaube kaum, dass entsprechende Inhalte entfernt werden.

  • Nachdem ich alle benötigten Pakete installiert hatte, wurden mir die folgenden Updates angeboten.



    Wie sieht es mit der Final des Chats aus? Müssen die Pakete vorher noch immer manuell installiert werden? Müssen sie vielleicht sogar wieder deinstalliert werden? *neugierig bin*

  • Hallo,

    Ich kenne den Chat noch nicht, wollte aber mal fragen, wie das mit der Speicherung von IP Adressen aussieht. Werden IP Adressen gespeichert? Wenn ja, wie lange? :)

    nein, der Chat speichert im Standardumfang keine IP-Adressen. Grundsätzlich erfolgt die Speicherung von Daten im Chat genau so lange, wie die Chatnachrichten gespeichert werden.


    Müssen sie vielleicht sogar wieder deinstalliert werden? *neugierig bin*

    Die Abhängigkeiten können auf dem System verbleiben, die sind bereits offiziell im Pluginstore veröffentlicht (deswegen hast du auch die Updates angeboten bekommen). Ich muss noch prüfen, ob ich die Abhängigkeiten später im Chat mitliefere oder nicht.

  • Hallo,


    wider Erwarten noch eine Beta 8. Für die ausstehenden Features der RC 1 muss ich mir noch größere Gedanken machen, daher einfach mal eine Version mit den schon gemachten Änderungen. Bitte unbedingt nochmal alles testen, ich habe eine ganze Menge Code durch die Gegend geschoben, um den internen Datenfluss vom Chat zu verbessern. Dabei ist unter Umständen etwas subtil kaputt gegangen.


    ACHTUNG: Es wurden größere Änderungen an den Templates vorgenommen. Etwaige eigene Versionen sind definitiv nicht kompatibel und müssen entsprechend angepasst werden:

    Code
    1. [timwolla@/s/Tims-Chat (master)]g d --stat v4.0.0-beta.7..v4.0.0-beta.8 -- templates
    2. templates/infoCommandSuspensions.tpl | 4 ++--
    3. templates/log.tpl | 44 +++++++++++++++++++++++++++-----------------
    4. templates/messageTypes.tpl | 44 +++++++++++++++++++++++---------------------
    5. templates/room.tpl | 18 ++++++++++++------
    6. templates/userListDropdownMenuItems.tpl | 13 ++++++++-----
    7. 5 files changed, 72 insertions(+), 51 deletions(-)